Back to overview
Degraded

Region Selection Failures

Sep 9, 2025 at 2:38pm UTC
Affected services
Main API

Resolved
Sep 9, 2025 at 5:08pm UTC

This should be resolved.

Created
Sep 9, 2025 at 2:38pm UTC

Region selection is failing due to an upstream issue with our global routing provider. We are looking into this.