Back to overview
Degraded
ORD Region is getting timeouts
Mar 07 at 12:07pm CST
Affected services
Main API
Resolved
Mar 07 at 12:18pm CST
We have identified the root cause and fixed the issue. Things should be back to smooth sailing.
Affected services
Created
Mar 07 at 12:07pm CST
We're looking into this and will provide an update here soon
Affected services