Back to overview
Downtime
Facing DNS Issues so some elements of our dashboard are failing
Mar 10 at 03:51pm CST
Affected services
Main - App
Resolved
Mar 10 at 03:55pm CST
We've pushed a temporary fix but it's not 100% just yet -- finalizing changes slowly.
Affected services
Created
Mar 10 at 03:51pm CST
We're investigating this thoroughly and will follow up with updates shortly
Affected services