Back to overview
Resolved
We're facing Domain/SSL issues
Jul 22, 2026 at 5:22am UTC
Affected services
Main API
Resolved
Jul 22, 2026 at 10:10am UTC
DNS has been restored
Affected services
Updated
Jul 22, 2026 at 9:25am UTC
IN THE MEANTIME, ALL USERS PLEASE USE https://http.steel-edge.net/ as an alternate domain for the API
Affected services
Created
Jul 22, 2026 at 5:22am UTC
All services are down currently
Affected services