Back to overview
Downtime
US East Region Facing Unprecedented Traffic
Nov 19 at 05:17am CST
Affected services
Main API
Resolved
Nov 19 at 05:38am CST
We've pushed a scaling fix and traffic is being balanced now. Will continue to monitor for any outliers.
Affected services
Created
Nov 19 at 05:17am CST
We're looking into it-- and we'll follow up with an update here shortly.
Affected services